What's new
SimRacing.Club

Welcome to SimRacing.Club
We are an online racing league, and has years of experience using S397´s rFactor 2. We have several series - VEC which is the official rFactor 2 endurance championship. 6-24 hour races - its all about endurance.
VEC´s feeder series Virtual Le Mans Series and several special events - Plenty of racing. Register today to become a member! Once signed in, you'll just need to introduce yourself and then you can start off in our Academy series

pls halp veles is poor

Carlos Santos

SRCA director
Messages
185
Reaction score
299
At least it was right after Le Mans :barefoot:, imagine if it was right before :eek:
 

Marius Nicolae

Messages
206
Reaction score
1,071
Imagine this , about my G25 ,he let me down( but still after 9 years ) in the morning test just before the first race of the season ....i found a G27 200 km away and driving like crazy there and back :)))) to be in time for my stint .
 

Ricardo Costa

Messages
27
Reaction score
9
At least it was right after Le Mans :barefoot:, imagine if it was right before :eek:
Yeah I was really lucky not having my wheel dying during the race!

It's kinda unbelievable for me, I always thought G27 would never break. Have it for a little over 6 years, it served me well anyways.
 

Matheus Machado

Messages
160
Reaction score
78
pretty sure it is a driver issue or something, my wheel had about the same and got back working, mine is clocking 10 years as of now. G27 never dies.
 

Yoeri Gijsen

Messages
381
Reaction score
260
I actually ordered a new metal optical encoder for my G27. It's been working well again for over a year now.
 

Povilas Miciunas

Messages
125
Reaction score
178
@Alen Terzic try and unplug the shifter. My G27 is also broken. Not sure if it's the same issue or not, but I've been running with it broken for way over a year now. It only works if the shifter is unplugged. If it's plugged in - the wheel does weird stuff and dies. It's apparently some issue with the motherboard or something (according to the internet)
 

Enzo Fazzi

Messages
1,247
Reaction score
645
@Alen Terzic try and unplug the shifter. My G27 is also broken. Not sure if it's the same issue or not, but I've been running with it broken for way over a year now. It only works if the shifter is unplugged. If it's plugged in - the wheel does weird stuff and dies. It's apparently some issue with the motherboard or something (according to the internet)
It's @Ricardo Costa's
 
Top